MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
00003063D-Coat v4.1Sculpting with voxels (Voxel room)public2011-07-24 08:012014-08-03 14:00
ReporterBeatKitano 
Assigned ToAndrew 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPCOSWindows 7OS Version(64 Bit)
Product Version 
Target VersionFixed in Version 
Summary0000306: Symmetry on a volume basis
DescriptionCould we have symmetry per volume ?

I often deactivate symmetry to work on an asymetrical volume and forget to reactivate it to work on another symmetrical volume leading to some headache with current liveclay integration since resymmetry in surface mode is converted to voxels (losing details).

Thank you.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003210)
BeatKitano (reporter)
2013-08-04 05:27

Bump.
(0003226)
BeatKitano (reporter)
2013-08-25 06:30

Rebump, major annoyance since resym command can create mesh issues such as explosions/holes/tears.
(0003463)
BeatKitano (reporter)
2014-01-19 08:05
edited on: 2014-01-19 08:41

bump. Zbrush has it, mudbox has it, helix has it.
One variable, a check, hard to write.

(0003474)
artman (reporter)
2014-01-20 19:33
edited on: 2014-01-20 19:34

Symm copy in SF mode does not convert to voxel.I dont know why you say this.

All Liveclay tesselation is mirrored and preserved.
There is absolutely no loss in details.

In SF mode it is exactly like Zbrush (it flips a copy and weld points at center)

(0003475)
BeatKitano (reporter)
2014-01-20 19:43

So we have a workaround tool so we don't need a smart workflow. 3dcoat's way !
Thank you.
(0003476)
artman (reporter)
2014-01-20 20:07
edited on: 2014-01-20 20:09

What workaround?
Symmetry in 3Dcoat is per volume and always has been.
I dont understand your request(Im not being sarcastic here)
Also you say Resym convert to voxels and its just not true...
its exactly like Zbrush..

I dont understand why you say "workaround"?

Do I understand correctly? ; By "per volume" you mean each volume has its own symmetry?

(0003477)
BeatKitano (reporter)
2014-01-20 20:12
edited on: 2014-01-20 20:17

No, symmetry is not per volume. Symmetry is global. Symmetry axis is per volume, that's the difference.

Toggle symmetry off, it's off for every tool.
That's stupid, on a model you may need symmetrical and asymmetrical parts, you can't have both mode when switching between parts: you're either symmetrical or you're not on ALL parts.
If I don't want symmetry on a model, I set it, done. As it currently stands I have to toggle it on and off depending on the part I'm working on. That's a waste of time, it's prone to human error, and there comes the "workaround tool": symmcopy. 3dcoat's way.

BTW, if you look at the report date (2011 !! yay !) it was still using voxel for resym, converting to surface mode afterwards, hence the detail loss.

(0003478)
artman (reporter)
2014-01-20 20:18
edited on: 2014-01-20 20:19

ohh....the toggling.Ok ,I understand. Good idea.I think you should rename your request like "Please Add "Remember Symmetry on/off for each layers in Preferences"
"per volume symmetry" is too vague.

also please dont say stuff like details loss ect...without verifying first.
Sym copy in Sf mode never converted model to voxels.Always preserved LC details(in all builds).I've been using it everyday since the introduction of LC.There is enough issues in 3DCoat already not to add fake ones on top of it.

(0003479)
BeatKitano (reporter)
2014-01-20 20:20
edited on: 2014-01-20 20:23

No, it was converting to voxel at that date, I'm not making things up here, it was corrected later on but at that time it was voxel>surface. I'M SURE of it.

proof: Raul said it here: http://farsthary.wordpress.com/2011/10/22/symm-copy-command/ [^]

(0003480)
artman (reporter)
2014-01-20 20:29

my bad,sorry...dont remember where I was in 2011,probably was playing Zelda or something. Hard to believe LC was already implemented.It does not feel that long ago.
(0003801)
Andrew (administrator)
2014-07-17 15:33

Agree, symmetry should be per volume. With new approach it is relatively easy to implment. The only question - if the volume has symmetry and you switched to volume where there was no symmetry set - should symmetry be disabled or kept as on previous volume? I think it should disappear, is it ok?
On other note - probaly symmetry should be transformed as well with transform tool, right?
(0003802)
artman (reporter)
2014-07-17 20:35
edited on: 2014-07-17 20:37

disabled...(anyway,I think this is what Beat was requesting)

More importantly for me is the ability to toggle it on/off using only one hotkey/function which is currently not possible,

By transformed what do you mean? I thought Its already working that way...and its definitely one on 3DCoat strongest feature I would even say I could not work in 3Dcoat without it....

another note (unrelated):
What would also be very useful would be to be able to pick/steal a symmetry plane from another volume with one click....

Right now method is a little complicated (clone space density then use Move to...also it works only in SF mode because moving to other space density in voxel mode change the details of volumes)


- Issue History
Date Modified Username Field Change
2011-07-24 08:01 BeatKitano New Issue
2011-07-24 08:02 BeatKitano Assigned To => Andrew
2011-07-24 08:02 BeatKitano Status new => assigned
2011-08-29 07:15 Taros Category Voxel room => Sculpting with voxels (Voxel room)
2013-02-28 12:48 BeatKitano Project 3D-Coat v3.x => 3D-Coat v4
2013-08-04 05:27 BeatKitano Note Added: 0003210
2013-08-25 06:30 BeatKitano Note Added: 0003226
2014-01-19 08:05 BeatKitano Note Added: 0003463
2014-01-19 08:41 BeatKitano Note Edited: 0003463 View Revisions
2014-01-20 19:33 artman Note Added: 0003474
2014-01-20 19:34 artman Note Edited: 0003474 View Revisions
2014-01-20 19:43 BeatKitano Note Added: 0003475
2014-01-20 19:43 BeatKitano Status assigned => closed
2014-01-20 19:43 BeatKitano Resolution open => fixed
2014-01-20 19:43 BeatKitano Status closed => feedback
2014-01-20 19:43 BeatKitano Resolution fixed => reopened
2014-01-20 20:07 artman Note Added: 0003476
2014-01-20 20:08 artman Note Edited: 0003476 View Revisions
2014-01-20 20:09 artman Note Edited: 0003476 View Revisions
2014-01-20 20:12 BeatKitano Note Added: 0003477
2014-01-20 20:12 BeatKitano Status feedback => assigned
2014-01-20 20:13 BeatKitano Note Edited: 0003477 View Revisions
2014-01-20 20:17 BeatKitano Note Edited: 0003477 View Revisions
2014-01-20 20:18 artman Note Added: 0003478
2014-01-20 20:19 artman Note Edited: 0003478 View Revisions
2014-01-20 20:20 BeatKitano Note Added: 0003479
2014-01-20 20:23 BeatKitano Note Edited: 0003479 View Revisions
2014-01-20 20:29 artman Note Added: 0003480
2014-07-17 11:34 carlosa Project 3D-Coat v4 => 3D-Coat v4.1
2014-07-17 15:33 Andrew Note Added: 0003801
2014-07-17 20:35 artman Note Added: 0003802
2014-07-17 20:37 artman Note Edited: 0003802 View Revisions
2014-07-27 19:10 artman Status assigned => resolved
2014-08-03 11:52 carlosa Status resolved => new
2014-08-03 14:00 carlosa Status new => resolved
2014-08-03 14:00 carlosa Resolution reopened => fixed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker