MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
00002523D-Coat v3.xPaint roompublic2011-04-20 11:202011-04-21 10:23
Reporteruser23 
Assigned ToAndrew 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformPCOSWindows 7OS Version64bit
Product Version 
Target VersionFixed in Version 
Summary0000252: Shift (Blur Brush) Artifacts
DescriptionPressing Shift in Paint room to blur pixels on current layer still has certain artifacts.
- Pixels seem to Darken where there are no existing dark pixels.
- Blur extends over the 'Freeze' boundary. (Freeze should be sacred)
Steps To Reproduce1. Paint on layer 0 with HSL Value 190,100,38.
2. Create a new layer above Layer 0.
3. Paint same HSL Value onto new layer.
4. With 'Draw with Brush' selected hold SHIFT and blur the pixels.

Notice that you end up with a Dark spot.

For Freeze artifact do the same as above but freeze part of the mesh and toggle freeze view (to view all pixels)
-Paint some pixels near the freeze border edge then SHIFT blur those pixels and notice the blurred pixels go over the Freeze section.
Additional InformationAdditionally after Step 3 if you hide Layer 0 to view your painted pixels you can see that there are some dark pixels on the edges of your painted stroke. The darkening might be related to this.

If I get time I will upload a video.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000626)
Andrew (administrator)
2011-04-20 12:47

Can't reproduce problems. After smoothing color looks the same. 100% frozen areas remain unchanged.
(0000629)
user23
2011-04-20 15:51
edited on: 2011-04-20 16:02

hi Andrew, I'm not sure why you can't reproduce this problem. I had my Art Director report this issue to me also, as well as other members of our team. We all get this result using the Shift tool to blur.

I will investigate further.
thanks

Just did a quick check with a colleague who has an NVIDIA Geforce GTS250 and he still gets the darkening problem but REALLY minimal, whereas..

I have an ATI Radeon HD 5700 Series card and the Darkening is VERY strong

(0000636)
Andrew (administrator)
2011-04-20 17:35

ok, reproduced and fixed. It happens with brushes with very sharp alpha on the edge
(0000640)
user23
2011-04-21 10:23

Brilliant, thanks Andrew

- Issue History
Date Modified Username Field Change
2011-04-20 11:20 user23 New Issue
2011-04-20 11:20 user23 Status new => assigned
2011-04-20 11:20 user23 Assigned To => Andrew
2011-04-20 12:47 Andrew Note Added: 0000626
2011-04-20 12:47 Andrew Status assigned => feedback
2011-04-20 15:51 user23 Note Added: 0000629
2011-04-20 15:51 user23 Status feedback => assigned
2011-04-20 16:02 user23 Note Edited: 0000629 View Revisions
2011-04-20 17:35 Andrew Note Added: 0000636
2011-04-20 17:35 Andrew Status assigned => resolved
2011-04-20 17:35 Andrew Resolution open => fixed
2011-04-21 10:23 user23 Note Added: 0000640


Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker