MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
00001283D-Coat v3.xOtherpublic2011-02-01 18:002011-02-16 17:11
ReporterGeeJay 
Assigned ToAndrew 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntu 64bitOS Version10.04
Product Version 
Target VersionFixed in Version 
Summary0000128: Panels that are open in one room get torn off in another
DescriptionIf I add a panel, for example presets, in the painting room, snap it to the interface and switch room it turns into a floating panel. If I then snap it in the other room too everything is ok.
Steps To ReproduceAdd color picker panel in paint room to the right side. Switch to Voxel room. Color picker turns into floating window. Correct behaviour would be for it to disappear.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000177)
haikalle (developer)
2011-02-02 08:50

Also happens in win version.
(0000180)
Andrew (administrator)
2011-02-02 16:09

I see that if I will not dock window but stay it floating, then it will not disappear (I assume it is correct), if it will be actually docked then it will disappear. I see no bug there.

The only possible issue is remaining of floating window.
(0000181)
guest (viewer)
2011-02-02 16:19
edited on: 2011-02-02 16:34

Andrew. Here is one video example where docked window become floating window when switching rooms. http://vimeo.com/19484483 [^]

I think it's okey to have feature that floating windows will go other rooms. But then we have to be carefull that no floating windows are created by bugs, because then it will affect all rooms.

(0000184)
GeeJay (reporter)
2011-02-02 17:20

Exactly what Haikalle described. Personally I would expect the colorpicker to disappear. Each room has an own layout that can be saved, that should be respected and changing something in one room should not carry over to another. For example, if I add the colorpicker in the paint room I would not want it to appear in the UV Room.
(0000196)
haikalle (developer)
2011-02-03 11:36

I would almost like to prefer that floating windows are not moving between rooms. I don't see reason for that. In fact for example UV preview window in UV room is floating and it dosen't move between rooms.

Like I said before floating windows moving between rooms are okey, but need to be very careful with bugs.
(0000197)
Andrew (administrator)
2011-02-04 12:53

Fixed after 3.5.11A
(0000306)
haikalle (developer)
2011-02-16 17:11

Fixed.

- Issue History
Date Modified Username Field Change
2011-02-01 18:00 GeeJay New Issue
2011-02-02 07:53 haikalle Assigned To => Andrew
2011-02-02 07:53 haikalle Status new => assigned
2011-02-02 08:50 haikalle Note Added: 0000177
2011-02-02 16:09 Andrew Note Added: 0000180
2011-02-02 16:09 Andrew Status assigned => feedback
2011-02-02 16:19 guest Note Added: 0000181
2011-02-02 16:34 guest Note Edited: 0000181 View Revisions
2011-02-02 16:36 haikalle Status feedback => assigned
2011-02-02 17:20 GeeJay Note Added: 0000184
2011-02-03 11:36 haikalle Note Added: 0000196
2011-02-04 12:53 Andrew Note Added: 0000197
2011-02-04 12:53 Andrew Status assigned => resolved
2011-02-04 12:53 Andrew Resolution open => fixed
2011-02-16 17:11 haikalle Note Added: 0000306
2011-02-16 17:11 haikalle Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker