MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
00001113D-Coat v3.xPaint roompublic2011-01-14 14:272011-04-20 15:59
ReporterTaros 
Assigned ToAndrew 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindows 7OS Version64 Bit
Product Version 
Target VersionFixed in Version 
Summary0000111: Blending Options Problem: Specular brightness
DescriptionThe specular brightness value does not work, when the color channel of a layer is empty.
Steps To Reproduce1. Create a new, empty layer
2. Paint some specular information only (No color and no depth)
3. Layer blending options: Set Specular brightness to a value of -50
-> Nothing happens

But if you paint some color channel information into this layer, then it works and can be seen.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000566)
haikalle (developer)
2011-04-13 14:42
edited on: 2011-04-13 15:16

Hi!

Just couple minutes ago you resolved one specular color issue:

http://www.3d-coat.com/mantis/view.php?id=205 [^]

does that mean that this issue also resolved? It wasen't a bug after all.
Just a little bit confusing how it works. But like Andrew said Specular brigtness has effect for painted areas and specular contrast has effect for all. Works for me :) In the end this gives more options for artist.

(0000587)
haikalle (developer)
2011-04-14 17:48

Taros, Is this ok for we close this one. In the end it's not a bug :)
(0000588)
Taros (administrator)
2011-04-15 08:01
edited on: 2011-04-15 08:02

No, I can't set this to closed.
To change the brightness or to change the contrast leads into two different results.
It should be possible to change the specular brightness of a layer, as it is possible to change the specular contrast. Where is the problem?

(0000591)
haikalle (developer)
2011-04-15 09:49

I agree that right now specular brightness is misleading what it actually do.
(0000592)
Andrew (administrator)
2011-04-15 10:52

Ok, I made that Specular brightness affects not only araeas that are painted but also specular areas that have no color alpha.
(0000632)
Taros (administrator)
2011-04-20 15:59
edited on: 2011-04-20 16:00

Perfect! Fixed since V. 3.5.18A


- Issue History
Date Modified Username Field Change
2011-01-14 14:27 Taros New Issue
2011-01-14 14:27 Taros Status new => assigned
2011-01-14 14:27 Taros Assigned To => Andrew
2011-04-13 14:42 haikalle Note Added: 0000566
2011-04-13 14:42 haikalle Status assigned => feedback
2011-04-13 14:42 haikalle Note Edited: 0000566 View Revisions
2011-04-13 14:43 haikalle Note Edited: 0000566 View Revisions
2011-04-13 15:14 haikalle Note Edited: 0000566 View Revisions
2011-04-13 15:15 haikalle Note Edited: 0000566 View Revisions
2011-04-13 15:16 haikalle Note Edited: 0000566 View Revisions
2011-04-14 17:48 haikalle Note Added: 0000587
2011-04-15 08:01 Taros Note Added: 0000588
2011-04-15 08:01 Taros Status feedback => assigned
2011-04-15 08:02 Taros Note Edited: 0000588 View Revisions
2011-04-15 08:02 Taros Note Edited: 0000588 View Revisions
2011-04-15 09:49 haikalle Note Added: 0000591
2011-04-15 10:52 Andrew Note Added: 0000592
2011-04-15 10:52 Andrew Status assigned => resolved
2011-04-15 10:52 Andrew Resolution open => fixed
2011-04-20 15:59 Taros Note Added: 0000632
2011-04-20 15:59 Taros Status resolved => closed
2011-04-20 16:00 Taros Note Edited: 0000632 View Revisions


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker