Jump to content


Photo
- - - - -

Posing Tool Question


  • Please log in to reply
13 replies to this topic

#1 Palex

Palex

    Neophyte

  • Member
  • Pip
  • 41 posts

Posted 12 September 2011 - 09:14 PM

Scenario: A character is in a T position. There is a layer for his body, and layers for his gloves/bracers. Is it possible to pose the arms so that the gloves and bracers stay aligned?

#2 artman

artman

    Expert

  • Contributor
  • PipPipPipPipPip
  • 2,019 posts
  • Gender:Male
  • Location:quebec,canada
  • Interests:Henri Corbin
    Brian Wilson
    Hikaru No Go
    Noah23
    and 3DCoat.

Posted 12 September 2011 - 09:44 PM

Scenario: A character is in a T position. There is a layer for his body, and layers for his gloves/bracers. Is it possible to pose the arms so that the gloves and bracers stay aligned?

Absolutely. :) Check "Through all volumes" checkbox in top left corner of screen when using Pose tool.
Pose tool will work using all visible voxel layers.
Lest limbs be reddened and rent--I spring the trap that is set--As I loose the snare you may glimpse me there--For surely you shall forget
"The Wind In the Willows", Chapter 7 "The Piper at the Gates Of Dawn"

#3 Palex

Palex

    Neophyte

  • Member
  • Pip
  • 41 posts

Posted 13 September 2011 - 12:06 AM

Thank you for the response, sir. I think I did not quite make my dilemma clear, however. I am aware of the through-all-volumes feature, but when I try to pose something and there are separate objects (like an arm with a bracer/glove), the objects fly off each other. They move in the same direction, but they become grossly misaligned, as if they are following different points on the same arc.

Perhaps I am not using the tool correctly.

#4 artman

artman

    Expert

  • Contributor
  • PipPipPipPipPip
  • 2,019 posts
  • Gender:Male
  • Location:quebec,canada
  • Interests:Henri Corbin
    Brian Wilson
    Hikaru No Go
    Noah23
    and 3DCoat.

Posted 13 September 2011 - 12:20 AM

Thank you for the response, sir. I think I did not quite make my dilemma clear, however. I am aware of the through-all-volumes feature, but when I try to pose something and there are separate objects (like an arm with a bracer/glove), the objects fly off each other. They move in the same direction, but they become grossly misaligned, as if they are following different points on the same arc.

Perhaps I am not using the tool correctly.

It should work,I jsut tried it and it work very well,even selectiing with line mode.
Maybe Make strong selections using lasso tool,select pen mode in Pose tool and select lasso manually in E-panel(press e)
be sure everything you want it well selected,and smooth selections with Shift where you want it to bend.
Can you post a screenshot? or your file?(mediafire)

Edit:I tried it on another file and I got an exploding mesh,not sure what is happening here.
I'll report issue to mantis.
Lest limbs be reddened and rent--I spring the trap that is set--As I loose the snare you may glimpse me there--For surely you shall forget
"The Wind In the Willows", Chapter 7 "The Piper at the Gates Of Dawn"

#5 Palex

Palex

    Neophyte

  • Member
  • Pip
  • 41 posts

Posted 13 September 2011 - 04:40 PM

Thank you for reporting it.

Here's a visual of what is happening, just as an example.

http://cl.ly/3S1s3Z1...11_38_03_AM.png

#6 artman

artman

    Expert

  • Contributor
  • PipPipPipPipPip
  • 2,019 posts
  • Gender:Male
  • Location:quebec,canada
  • Interests:Henri Corbin
    Brian Wilson
    Hikaru No Go
    Noah23
    and 3DCoat.

Posted 13 September 2011 - 04:53 PM

Thank you for reporting it.

Here's a visual of what is happening, just as an example.

http://cl.ly/3S1s3Z1...11_38_03_AM.png



It seems your objects are not even selected.
What selection method do you use?
Selection is either "dark grey" or a "Rainbow gradient" depending on what shader you got on.

(after further investigation,my mesh exploding issue is totally not related to yours)
Lest limbs be reddened and rent--I spring the trap that is set--As I loose the snare you may glimpse me there--For surely you shall forget
"The Wind In the Willows", Chapter 7 "The Piper at the Gates Of Dawn"

#7 Palex

Palex

    Neophyte

  • Member
  • Pip
  • 41 posts

Posted 13 September 2011 - 05:10 PM

They're selected. Here's the image again with an indicator (red arrow) of where the selection starts.

http://cl.ly/2k161x0...12_07_42_PM.png

Here's the before-posing image, with the objects selected.

http://cl.ly/13110w0...12_09_24_PM.png

#8 artman

artman

    Expert

  • Contributor
  • PipPipPipPipPip
  • 2,019 posts
  • Gender:Male
  • Location:quebec,canada
  • Interests:Henri Corbin
    Brian Wilson
    Hikaru No Go
    Noah23
    and 3DCoat.

Posted 13 September 2011 - 05:38 PM

They're selected. Here's the image again with an indicator (red arrow) of where the selection starts.

http://cl.ly/2k161x0...12_07_42_PM.png

Here's the before-posing image, with the objects selected.

http://cl.ly/13110w0...12_09_24_PM.png

Okay,your selection is clearly obvious...sorry.

And I tried it its definitely broken,it seems to be using wrong pivots of objects.Im reporting now.

Edit:Reported to Mantis,Major issues like that gets fixed pretty fast usually.
Lest limbs be reddened and rent--I spring the trap that is set--As I loose the snare you may glimpse me there--For surely you shall forget
"The Wind In the Willows", Chapter 7 "The Piper at the Gates Of Dawn"

#9 Palex

Palex

    Neophyte

  • Member
  • Pip
  • 41 posts

Posted 13 September 2011 - 06:40 PM

You're the man. Thanks again.

#10 Andrew Shpagin

Andrew Shpagin

    3DC creator & admin

  • 3D-Coat Developer
  • PipPipPipPipPipPip
  • 6,541 posts

  • Gender:Male

Posted 14 September 2011 - 10:44 AM

It could be very good if you will send me model (zipped 3B) to support. It will help to find roots of problem easily.

#11 artman

artman

    Expert

  • Contributor
  • PipPipPipPipPip
  • 2,019 posts
  • Gender:Male
  • Location:quebec,canada
  • Interests:Henri Corbin
    Brian Wilson
    Hikaru No Go
    Noah23
    and 3DCoat.

Posted 14 September 2011 - 03:23 PM

It could be very good if you will send me model (zipped 3B) to support. It will help to find roots of problem easily.

Here is one file,its 14.5 mb.Not heavy but I still cannot email it.
http://www.mediafire...dhr0c4oba34gxfa
I added a cylinder primitive on arm to act as bracelet.
Try to rotate arm along with bracelet.

(it seems selected voxel layer gives different results,Pose gizmo pivot center should override all voxel layers and transformation should give same
result regardless of layer selected.)

with same file you can also test the "transform as a whole" issue in Freeform mode I reported on Mantis.It does not work.

Also another issue is the fact that the gizmo sometimes change position when navigating while E-panel slection modes are on,very annoying issue.
Lest limbs be reddened and rent--I spring the trap that is set--As I loose the snare you may glimpse me there--For surely you shall forget
"The Wind In the Willows", Chapter 7 "The Piper at the Gates Of Dawn"

#12 Andrew Shpagin

Andrew Shpagin

    3DC creator & admin

  • 3D-Coat Developer
  • PipPipPipPipPipPip
  • 6,541 posts

  • Gender:Male

Posted 15 September 2011 - 06:55 PM

Here is one file,its 14.5 mb.Not heavy but I still cannot email it.
http://www.mediafire...dhr0c4oba34gxfa
I added a cylinder primitive on arm to act as bracelet.
Try to rotate arm along with bracelet.

(it seems selected voxel layer gives different results,Pose gizmo pivot center should override all voxel layers and transformation should give same
result regardless of layer selected.)

with same file you can also test the "transform as a whole" issue in Freeform mode I reported on Mantis.It does not work.

Also another issue is the fact that the gizmo sometimes change position when navigating while E-panel slection modes are on,very annoying issue.

Thanks for file, it clearly shows the problem.
Fixed :)

#13 Palex

Palex

    Neophyte

  • Member
  • Pip
  • 41 posts

Posted 17 September 2011 - 02:45 AM

Thanks!

#14 AbnRanger

AbnRanger

    Expert

  • Contributor
  • PipPipPipPipPip
  • 4,937 posts
  • Gender:Male

Posted 17 September 2011 - 12:15 PM

I've been seeing a bad bug (3.5.24), where hitting UNDO will wipe out ALL your Retopo Layers. Hitting UNDO a few more times sometimes will bring them back. Sometimes not. Got so bad that it just happened and 3DC closed itself instantly...no hanging...no crash warning/report. So, anyone doing retopo work needs to save every 10 mins or so.

Hard to get it to repeat the behavior predictably. It just does it at various times, but when it happens it always involves hitting UNDO.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users